Get in touch
Back
Maintenance

SSL Renewal

Completed 22 Jul at 12:30pm CEST.

Uptime Uptime retourenportaal.nl
Completed

Maintenance completed

Posted 22 Jul at 12:30pm CEST.
Updated

We are currently renewing the SSL of our returnportals, this may take some time and will also affect the dashboard.

Posted 22 Jul at 12:26pm CEST.
Started

The returnportal is currently unavailable for most users. We have put the server into maintenance mode and wil inform you of any updates.

Posted 17 Jul at 01:13am CEST.